mcu install conflict - should I care?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

mcu install conflict - should I care?

Yama Ploskonka-2
Should I care that when trying to install msp430mcu there is a conflict?

The code I have been using for testing compiles OK - I actually have no
idea what mcu is for, or whether I need it at all. Were it not that
http://sourceforge.net/apps/mediawiki/mspgcc/index.php?title=MSPGCC_Wiki
says "The msp430mcu
<http://sourceforge.net/projects/mspgcc/files/msp430mcu> package must be
installed to provide header and linker support." I would not worry.

I've been having assorted difficulties compiling for Launchpad run from
OLPC XO, so I decided to reinstall the OS, load the mspdebug toolchain
from zero.



(follows log of install in OLPC XO-1, using OLPC OS 2021o0 release 12.1.0)

  Dup dor a'az Mubster!              \_____/    Bonjour, enfants du monde!
  Ciao, bambini di tutto il mondo!   || o ||    ¡Hola, chicos del mundo!
  Hallo, Kinder der Welt!            |._X_.|    Hallo, kinderen van de
wereld!
  Hello, children of the world!     //_=_=_\\   Olá, crianças do mundo!

[olpc@xo-12-37-77 ~]$ cd Documents/
[olpc@xo-12-37-77 Documents]$ sudo yum install mspdebug msp430-libc
fedora/metalink                                          |  19 kB     00:00
fedora                                                   | 4.2 kB     00:00
fedora/primary_db                                        |  12 MB     00:39
olpc-f17                                                 |  951 B     00:00
olpc-f17/primary                                         |  17 kB     00:00
olpc-f17 82/82
olpc-f17-xo1                                             |  951 B     00:00
olpc-f17-xo1/primary                                     |  19 kB     00:00
olpc-f17-xo1 190/190
updates/metalink                                         |  12 kB     00:00
updates                                                  | 4.7 kB     00:00
http://fedora.mirror.constant.com/linux/updates/17/i386/repodata/repomd.xml: 
[Errno -1] repomd.xml does not match metalink for updates
Trying other mirror.
updates                                                  | 4.7 kB     00:00
updates/primary_db                                       | 5.6 MB     00:16
Resolving Dependencies
--> Running transaction check
---> Package msp430-libc.noarch 0:0-5.20090726cvs.fc17 will be installed
--> Processing Dependency: msp430-gcc for package:
msp430-libc-0-5.20090726cvs.fc17.noarch
---> Package mspdebug.i686 0:0.20-1.fc17 will be installed
--> Running transaction check
---> Package msp430-gcc.i686 0:3.2.3-6.20100805cvs.fc17 will be installed
--> Processing Dependency: msp430-binutils for package:
msp430-gcc-3.2.3-6.20100805cvs.fc17.i686
--> Running transaction check
---> Package msp430-binutils.i686 0:2.19.1-4.fc17 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
  Package             Arch       Version Repository   Size
================================================================================
Installing:
  msp430-libc         noarch     0-5.20090726cvs.fc17 fedora      204 k
  mspdebug            i686       0.20-1.fc17 updates     109 k
Installing for dependencies:
  msp430-binutils     i686       2.19.1-4.fc17 fedora      1.3 M
  msp430-gcc          i686       3.2.3-6.20100805cvs.fc17 fedora      1.2 M

Transaction Summary
================================================================================
Install  2 Packages (+2 Dependent packages)

Total download size: 2.8 M
Installed size: 19 M
Is this ok [y/N]: y
Downloading Packages:
(1/4): msp430-binutils-2.19.1-4.fc17.i686.rpm            | 1.3 MB     00:04
warning: rpmts_HdrFromFdno: Header V3 RSA/SHA256 Signature, key ID
1aca3465: NOKEY
Public key for msp430-binutils-2.19.1-4.fc17.i686.rpm is not installed
(2/4): msp430-gcc-3.2.3-6.20100805cvs.fc17.i686.rpm      | 1.2 MB     00:03
(3/4): msp430-libc-0-5.20090726cvs.fc17.noarch.rpm       | 204 kB     00:00
(4/4): mspdebug-0.20-1.fc17.i686.rpm                     | 109 kB     00:00
Public key for mspdebug-0.20-1.fc17.i686.rpm is not installed
--------------------------------------------------------------------------------
Total                                           276 kB/s | 2.8 MB     00:10
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-i386
Importing GPG key 0x1ACA3465:
  Userid     : "Fedora (17) <[hidden email]>"
  Fingerprint: cac4 3fb7 74a4 a673 d81c 5de7 50e9 4c99 1aca 3465
  Package    : fedora-release-17-1.noarch (@koji.dist-f17-i686/$releasever)
  From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-i386
Is this ok [y/N]: y
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
   Installing :
msp430-binutils-2.19.1-4.fc17.i686                           1/4
   Installing :
msp430-gcc-3.2.3-6.20100805cvs.fc17.i686                     2/4
   Installing :
msp430-libc-0-5.20090726cvs.fc17.noarch                      3/4
   Installing :
mspdebug-0.20-1.fc17.i686                                    4/4


Rpmdb checksum is invalid: dCDPT(pkg checksums): msp430-libc.noarch
0:0-5.20090726cvs.fc17 - u
[olpc@xo-12-37-77 Documents]$ ls
m2.c  shiftl2.c  shiftl.c  text.c

// the following is a test of the compiler

[olpc@xo-12-37-77 Documents]$ msp430-gcc -g shiftl.c -o t
[olpc@xo-12-37-77 Documents]$ ls
m2.c  shiftl2.c  shiftl.c  t  text.c

// trying to install the mcu

[olpc@xo-12-37-77 Documents]$ sudo yum install msp430mcu
Resolving Dependencies
--> Running transaction check
---> Package msp430mcu.noarch 0:20120406-4.fc17 will be installed
--> Processing Conflict: msp430mcu-20120406-4.fc17.noarch conflicts
msp430-libc < 20120224
--> Finished Dependency Resolution
Error: msp430mcu conflicts with msp430-libc-0-5.20090726cvs.fc17.noarch
  You could try using --skip-broken to work around the problem
  You could try running: rpm -Va --nofiles --nodigest

// also, the include looks thin - but so far works...

[olpc@xo-12-37-77 Documents]$ ls /usr/msp430/include
ctype.h        msp430x11x.h   msp430x20x3.h  msp430x31x.h msp430xG42x0.h
debug.h        msp430x12x2.h  msp430x21x1.h  msp430x32x.h msp430xG43x.h
errno.h        msp430x12x.h   msp430x21x2.h  msp430x33x.h msp430xG461x.h
io.h           msp430x13x1.h  msp430x22x2.h  msp430x41x.h msp430xW42x.h
iomacros.h     msp430x13x.h   msp430x22x4.h  msp430x42x0.h  setjmp.h
isr_compat.h   msp430x14x1.h  msp430x23x0.h  msp430x42x.h   signal.h
limits.h       msp430x14x.h   msp430x23x.h   msp430x43x.h   stdint.h
math.h         msp430x15x.h   msp430x241x.h  msp430x44x.h   stdio.h
msp430         msp430x16x.h   msp430x24x1.h  msp430x47xx.h  stdlib.h
msp430x11x1.h  msp430x20x1.h  msp430x24x.h   msp430x54xx.h  string.h
msp430x11x2.h  msp430x20x2.h  msp430x261x.h  msp430xE42x.h  sys
[olpc@xo-12-37-77 Documents]$



------------------------------------------------------------------------------
Monitor your physical, virtual and cloud infrastructure from a single
web console. Get in-depth insight into apps, servers, databases, vmware,
SAP, cloud infrastructure, etc. Download 30-day Free Trial.
Pricing starts from $795 for 25 servers or applications!
http://p.sf.net/sfu/zoho_dev2dev_nov
_______________________________________________
Mspgcc-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mspgcc-users
Reply | Threaded
Open this post in threaded view
|

Re: mcu install conflict - should I care?

Peter Bigot-4
Looks like the RPM packages for mspgcc you're finding are extremely out of
date; mspgcc 3.2.3 is no longer supported.  There was somebody who was
bundling more recent ones, but  I haven't seen anything from him recently.

The msp430mcu package is irrelevant to the version of mspgcc you get with
those RPMs, and that version wouldn't work with the launchpad.

If you need a package-based solution, you'll need to find somebody who has
current (LTS-20120406, probably) RPMs available.  Alternatively you can
build the LTS version or the most recent development version manually;
there are general instructions on the Wiki.

Peter


On Fri, Nov 23, 2012 at 10:45 PM, Yama Ploskonka <[hidden email]> wrote:

> Should I care that when trying to install msp430mcu there is a conflict?
>
> The code I have been using for testing compiles OK - I actually have no
> idea what mcu is for, or whether I need it at all. Were it not that
> http://sourceforge.net/apps/**mediawiki/mspgcc/index.php?**
> title=MSPGCC_Wiki<http://sourceforge.net/apps/mediawiki/mspgcc/index.php?title=MSPGCC_Wiki>
> says "The msp430mcu <http://sourceforge.net/**projects/mspgcc/files/**
> msp430mcu <http://sourceforge.net/projects/mspgcc/files/msp430mcu>>
> package must be installed to provide header and linker support." I would
> not worry.
>
> I've been having assorted difficulties compiling for Launchpad run from
> OLPC XO, so I decided to reinstall the OS, load the mspdebug toolchain from
> zero.
>
>
>
> (follows log of install in OLPC XO-1, using OLPC OS 2021o0 release 12.1.0)
>
>  Dup dor a'az Mubster!              \_____/    Bonjour, enfants du monde!
>  Ciao, bambini di tutto il mondo!   || o ||    ĄHola, chicos del mundo!
>  Hallo, Kinder der Welt!            |._X_.|    Hallo, kinderen van de
> wereld!
>  Hello, children of the world!     //_=_=_\\   Olá, crianças do mundo!
>
> [olpc@xo-12-37-77 ~]$ cd Documents/
> [olpc@xo-12-37-77 Documents]$ sudo yum install mspdebug msp430-libc
> fedora/metalink                                          |  19 kB     00:00
> fedora                                                   | 4.2 kB     00:00
> fedora/primary_db                                        |  12 MB     00:39
> olpc-f17                                                 |  951 B     00:00
> olpc-f17/primary                                         |  17 kB     00:00
> olpc-f17 82/82
> olpc-f17-xo1                                             |  951 B     00:00
> olpc-f17-xo1/primary                                     |  19 kB     00:00
> olpc-f17-xo1 190/190
> updates/metalink                                         |  12 kB     00:00
> updates                                                  | 4.7 kB     00:00
> http://fedora.mirror.constant.**com/linux/updates/17/i386/**
> repodata/repomd.xml<http://fedora.mirror.constant.com/linux/updates/17/i386/repodata/repomd.xml>:
> [Errno -1] repomd.xml does not match metalink for updates
> Trying other mirror.
> updates                                                  | 4.7 kB     00:00
> updates/primary_db                                       | 5.6 MB     00:16
> Resolving Dependencies
> --> Running transaction check
> ---> Package msp430-libc.noarch 0:0-5.20090726cvs.fc17 will be installed
> --> Processing Dependency: msp430-gcc for package:
> msp430-libc-0-5.20090726cvs.**fc17.noarch
> ---> Package mspdebug.i686 0:0.20-1.fc17 will be installed
> --> Running transaction check
> ---> Package msp430-gcc.i686 0:3.2.3-6.20100805cvs.fc17 will be installed
> --> Processing Dependency: msp430-binutils for package: msp430-gcc-3.2.3-6.
> **20100805cvs.fc17.i686
> --> Running transaction check
> ---> Package msp430-binutils.i686 0:2.19.1-4.fc17 will be installed
> --> Finished Dependency Resolution
>
> Dependencies Resolved
>
> ==============================**==============================**
> ====================
>  Package             Arch       Version Repository   Size
> ==============================**==============================**
> ====================
> Installing:
>  msp430-libc         noarch     0-5.20090726cvs.fc17 fedora      204 k
>  mspdebug            i686       0.20-1.fc17 updates     109 k
> Installing for dependencies:
>  msp430-binutils     i686       2.19.1-4.fc17 fedora      1.3 M
>  msp430-gcc          i686       3.2.3-6.20100805cvs.fc17 fedora      1.2 M
>
> Transaction Summary
> ==============================**==============================**
> ====================
> Install  2 Packages (+2 Dependent packages)
>
> Total download size: 2.8 M
> Installed size: 19 M
> Is this ok [y/N]: y
> Downloading Packages:
> (1/4): msp430-binutils-2.19.1-4.fc17.**i686.rpm            | 1.3 MB
> 00:04
> warning: rpmts_HdrFromFdno: Header V3 RSA/SHA256 Signature, key ID
> 1aca3465: NOKEY
> Public key for msp430-binutils-2.19.1-4.fc17.**i686.rpm is not installed
> (2/4): msp430-gcc-3.2.3-6.**20100805cvs.fc17.i686.rpm      | 1.2 MB
> 00:03
> (3/4): msp430-libc-0-5.20090726cvs.**fc17.noarch.rpm       | 204 kB
> 00:00
> (4/4): mspdebug-0.20-1.fc17.i686.rpm                     | 109 kB     00:00
> Public key for mspdebug-0.20-1.fc17.i686.rpm is not installed
> ------------------------------**------------------------------**
> --------------------
> Total                                           276 kB/s | 2.8 MB     00:10
> Retrieving key from file:///etc/pki/rpm-gpg/RPM-**GPG-KEY-fedora-i386
> Importing GPG key 0x1ACA3465:
>  Userid     : "Fedora (17) <[hidden email]>"
>  Fingerprint: cac4 3fb7 74a4 a673 d81c 5de7 50e9 4c99 1aca 3465
>  Package    : fedora-release-17-1.noarch (@koji.dist-f17-i686/$**
> releasever)
>  From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-**fedora-i386
> Is this ok [y/N]: y
> Running Transaction Check
> Running Transaction Test
> Transaction Test Succeeded
> Running Transaction
>   Installing : msp430-binutils-2.19.1-4.fc17.**i686
>     1/4
>   Installing : msp430-gcc-3.2.3-6.**20100805cvs.fc17.i686
>     2/4
>   Installing : msp430-libc-0-5.20090726cvs.**fc17.noarch
>      3/4
>   Installing : mspdebug-0.20-1.fc17.i686
>  4/4
>
>
> Rpmdb checksum is invalid: dCDPT(pkg checksums): msp430-libc.noarch
> 0:0-5.20090726cvs.fc17 - u
> [olpc@xo-12-37-77 Documents]$ ls
> m2.c  shiftl2.c  shiftl.c  text.c
>
> // the following is a test of the compiler
>
> [olpc@xo-12-37-77 Documents]$ msp430-gcc -g shiftl.c -o t
> [olpc@xo-12-37-77 Documents]$ ls
> m2.c  shiftl2.c  shiftl.c  t  text.c
>
> // trying to install the mcu
>
> [olpc@xo-12-37-77 Documents]$ sudo yum install msp430mcu
> Resolving Dependencies
> --> Running transaction check
> ---> Package msp430mcu.noarch 0:20120406-4.fc17 will be installed
> --> Processing Conflict: msp430mcu-20120406-4.fc17.**noarch conflicts
> msp430-libc < 20120224
> --> Finished Dependency Resolution
> Error: msp430mcu conflicts with msp430-libc-0-5.20090726cvs.**fc17.noarch
>  You could try using --skip-broken to work around the problem
>  You could try running: rpm -Va --nofiles --nodigest
>
> // also, the include looks thin - but so far works...
>
> [olpc@xo-12-37-77 Documents]$ ls /usr/msp430/include
> ctype.h        msp430x11x.h   msp430x20x3.h  msp430x31x.h msp430xG42x0.h
> debug.h        msp430x12x2.h  msp430x21x1.h  msp430x32x.h msp430xG43x.h
> errno.h        msp430x12x.h   msp430x21x2.h  msp430x33x.h msp430xG461x.h
> io.h           msp430x13x1.h  msp430x22x2.h  msp430x41x.h msp430xW42x.h
> iomacros.h     msp430x13x.h   msp430x22x4.h  msp430x42x0.h  setjmp.h
> isr_compat.h   msp430x14x1.h  msp430x23x0.h  msp430x42x.h   signal.h
> limits.h       msp430x14x.h   msp430x23x.h   msp430x43x.h   stdint.h
> math.h         msp430x15x.h   msp430x241x.h  msp430x44x.h   stdio.h
> msp430         msp430x16x.h   msp430x24x1.h  msp430x47xx.h  stdlib.h
> msp430x11x1.h  msp430x20x1.h  msp430x24x.h   msp430x54xx.h  string.h
> msp430x11x2.h  msp430x20x2.h  msp430x261x.h  msp430xE42x.h  sys
> [olpc@xo-12-37-77 Documents]$
>
>
>
>
> ------------------------------------------------------------------------------
> Monitor your physical, virtual and cloud infrastructure from a single
> web console. Get in-depth insight into apps, servers, databases, vmware,
> SAP, cloud infrastructure, etc. Download 30-day Free Trial.
> Pricing starts from $795 for 25 servers or applications!
> http://p.sf.net/sfu/zoho_dev2dev_nov
> _______________________________________________
> Mspgcc-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/mspgcc-users
>
>

------------------------------------------------------------------------------
Monitor your physical, virtual and cloud infrastructure from a single
web console. Get in-depth insight into apps, servers, databases, vmware,
SAP, cloud infrastructure, etc. Download 30-day Free Trial.
Pricing starts from $795 for 25 servers or applications!
http://p.sf.net/sfu/zoho_dev2dev_nov
_______________________________________________
Mspgcc-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mspgcc-users
Reply | Threaded
Open this post in threaded view
|

Fedora 17 RPM bundle, was Re: mcu install conflict - should I care?

Yama Ploskonka-2
I might be able to find someone to package the thing, or might try the
list also

Question: what needs to be packaged (files, dependencies?)
so far I know of

mspdebug
msp430-libc
msp430-binutils
msp430-gcc

Thank you!



On 11/24/2012 05:23 AM, Peter Bigot wrote:

> Looks like the RPM packages for mspgcc you're finding are extremely
> out of date; mspgcc 3.2.3 is no longer supported. There was somebody
> who was bundling more recent ones, but  I haven't seen anything from
> him recently.
>
> The msp430mcu package is irrelevant to the version of mspgcc you get
> with those RPMs, and that version wouldn't work with the launchpad.
>
> If you need a package-based solution, you'll need to find somebody who
> has current (LTS-20120406, probably) RPMs available. Alternatively you
> can build the LTS version or the most recent development version
> manually; there are general instructions on the Wiki.
>
> Peter
>
>
> On Fri, Nov 23, 2012 at 10:45 PM, Yama Ploskonka <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>     Should I care that when trying to install msp430mcu there is a
>     conflict?
>
>     The code I have been using for testing compiles OK - I actually
>     have no idea what mcu is for, or whether I need it at all. Were it
>     not that
>     http://sourceforge.net/apps/mediawiki/mspgcc/index.php?title=MSPGCC_Wiki
>     says "The msp430mcu
>     <http://sourceforge.net/projects/mspgcc/files/msp430mcu> package
>     must be installed to provide header and linker support." I would
>     not worry.
>
>     I've been having assorted difficulties compiling for Launchpad run
>     from OLPC XO, so I decided to reinstall the OS, load the mspdebug
>     toolchain from zero.
>
>
>
>     (follows log of install in OLPC XO-1, using OLPC OS 2021o0 release
>     12.1.0)
>
>      Dup dor a'az Mubster!              \_____/    Bonjour, enfants du
>     monde!
>      Ciao, bambini di tutto il mondo!   || o ||    ĄHola, chicos del
>     mundo!
>      Hallo, Kinder der Welt!            |._X_.|    Hallo, kinderen van
>     de wereld!
>      Hello, children of the world!     //_=_=_\\   Olá, crianças do mundo!
>
>     [olpc@xo-12-37-77 ~]$ cd Documents/
>     [olpc@xo-12-37-77 Documents]$ sudo yum install mspdebug msp430-libc
>     fedora/metalink                                          |  19 kB
>         00:00
>     fedora                                                   | 4.2 kB
>         00:00
>     fedora/primary_db                                        |  12 MB
>         00:39
>     olpc-f17                                                 |  951 B
>         00:00
>     olpc-f17/primary                                         |  17 kB
>         00:00
>     olpc-f17 82/82
>     olpc-f17-xo1                                             |  951 B
>         00:00
>     olpc-f17-xo1/primary                                     |  19 kB
>         00:00
>     olpc-f17-xo1 190/190
>     updates/metalink                                         |  12 kB
>         00:00
>     updates                                                  | 4.7 kB
>         00:00
>     http://fedora.mirror.constant.com/linux/updates/17/i386/repodata/repomd.xml:
>     [Errno -1] repomd.xml does not match metalink for updates
>     Trying other mirror.
>     updates                                                  | 4.7 kB
>         00:00
>     updates/primary_db                                       | 5.6 MB
>         00:16
>     Resolving Dependencies
>     --> Running transaction check
>     ---> Package msp430-libc.noarch 0:0-5.20090726cvs.fc17 will be
>     installed
>     --> Processing Dependency: msp430-gcc for package:
>     msp430-libc-0-5.20090726cvs.fc17.noarch
>     ---> Package mspdebug.i686 0:0.20-1.fc17 will be installed
>     --> Running transaction check
>     ---> Package msp430-gcc.i686 0:3.2.3-6.20100805cvs.fc17 will be
>     installed
>     --> Processing Dependency: msp430-binutils for package:
>     msp430-gcc-3.2.3-6.20100805cvs.fc17.i686
>     --> Running transaction check
>     ---> Package msp430-binutils.i686 0:2.19.1-4.fc17 will be installed
>     --> Finished Dependency Resolution
>
>     Dependencies Resolved
>
>     ================================================================================
>      Package             Arch       Version Repository   Size
>     ================================================================================
>     Installing:
>      msp430-libc         noarch     0-5.20090726cvs.fc17 fedora      204 k
>      mspdebug            i686       0.20-1.fc17 updates     109 k
>     Installing for dependencies:
>      msp430-binutils     i686       2.19.1-4.fc17 fedora  1.3 M
>      msp430-gcc          i686       3.2.3-6.20100805cvs.fc17 fedora  
>        1.2 M
>
>     Transaction Summary
>     ================================================================================
>     Install  2 Packages (+2 Dependent packages)
>
>     Total download size: 2.8 M
>     Installed size: 19 M
>     Is this ok [y/N]: y
>     Downloading Packages:
>     (1/4): msp430-binutils-2.19.1-4.fc17.i686.rpm            | 1.3 MB
>         00:04
>     warning: rpmts_HdrFromFdno: Header V3 RSA/SHA256 Signature, key ID
>     1aca3465: NOKEY
>     Public key for msp430-binutils-2.19.1-4.fc17.i686.rpm is not installed
>     (2/4): msp430-gcc-3.2.3-6.20100805cvs.fc17.i686.rpm      | 1.2 MB
>         00:03
>     (3/4): msp430-libc-0-5.20090726cvs.fc17.noarch.rpm       | 204 kB
>         00:00
>     (4/4): mspdebug-0.20-1.fc17.i686.rpm                     | 109 kB
>         00:00
>     Public key for mspdebug-0.20-1.fc17.i686.rpm is not installed
>     --------------------------------------------------------------------------------
>     Total                                           276 kB/s | 2.8 MB
>         00:10
>     Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-i386
>     Importing GPG key 0x1ACA3465:
>      Userid     : "Fedora (17) <[hidden email]
>     <mailto:[hidden email]>>"
>      Fingerprint: cac4 3fb7 74a4 a673 d81c 5de7 50e9 4c99 1aca 3465
>      Package    : fedora-release-17-1.noarch
>     (@koji.dist-f17-i686/$releasever)
>      From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-i386
>     Is this ok [y/N]: y
>     Running Transaction Check
>     Running Transaction Test
>     Transaction Test Succeeded
>     Running Transaction
>       Installing : msp430-binutils-2.19.1-4.fc17.i686                 1/4
>       Installing : msp430-gcc-3.2.3-6.20100805cvs.fc17.i686          
>           2/4
>       Installing : msp430-libc-0-5.20090726cvs.fc17.noarch            
>        3/4
>       Installing : mspdebug-0.20-1.fc17.i686                4/4
>
>
>     Rpmdb checksum is invalid: dCDPT(pkg checksums):
>     msp430-libc.noarch 0:0-5.20090726cvs.fc17 - u
>     [olpc@xo-12-37-77 Documents]$ ls
>     m2.c  shiftl2.c  shiftl.c  text.c
>
>     // the following is a test of the compiler
>
>     [olpc@xo-12-37-77 Documents]$ msp430-gcc -g shiftl.c -o t
>     [olpc@xo-12-37-77 Documents]$ ls
>     m2.c  shiftl2.c  shiftl.c  t  text.c
>
>     // trying to install the mcu
>
>     [olpc@xo-12-37-77 Documents]$ sudo yum install msp430mcu
>     Resolving Dependencies
>     --> Running transaction check
>     ---> Package msp430mcu.noarch 0:20120406-4.fc17 will be installed
>     --> Processing Conflict: msp430mcu-20120406-4.fc17.noarch
>     conflicts msp430-libc < 20120224
>     --> Finished Dependency Resolution
>     Error: msp430mcu conflicts with
>     msp430-libc-0-5.20090726cvs.fc17.noarch
>      You could try using --skip-broken to work around the problem
>      You could try running: rpm -Va --nofiles --nodigest
>
>     // also, the include looks thin - but so far works...
>
>     [olpc@xo-12-37-77 Documents]$ ls /usr/msp430/include
>     ctype.h        msp430x11x.h   msp430x20x3.h  msp430x31x.h
>     msp430xG42x0.h
>     debug.h        msp430x12x2.h  msp430x21x1.h  msp430x32x.h
>     msp430xG43x.h
>     errno.h        msp430x12x.h   msp430x21x2.h  msp430x33x.h
>     msp430xG461x.h
>     io.h           msp430x13x1.h  msp430x22x2.h  msp430x41x.h
>     msp430xW42x.h
>     iomacros.h     msp430x13x.h   msp430x22x4.h  msp430x42x0.h  setjmp.h
>     isr_compat.h   msp430x14x1.h  msp430x23x0.h  msp430x42x.h signal.h
>     limits.h       msp430x14x.h   msp430x23x.h   msp430x43x.h stdint.h
>     math.h         msp430x15x.h   msp430x241x.h  msp430x44x.h stdio.h
>     msp430         msp430x16x.h   msp430x24x1.h  msp430x47xx.h  stdlib.h
>     msp430x11x1.h  msp430x20x1.h  msp430x24x.h   msp430x54xx.h  string.h
>     msp430x11x2.h  msp430x20x2.h  msp430x261x.h  msp430xE42x.h  sys
>     [olpc@xo-12-37-77 Documents]$
>
>
>
>     ------------------------------------------------------------------------------
>     Monitor your physical, virtual and cloud infrastructure from a single
>     web console. Get in-depth insight into apps, servers, databases,
>     vmware,
>     SAP, cloud infrastructure, etc. Download 30-day Free Trial.
>     Pricing starts from $795 for 25 servers or applications!
>     http://p.sf.net/sfu/zoho_dev2dev_nov
>     _______________________________________________
>     Mspgcc-users mailing list
>     [hidden email]
>     <mailto:[hidden email]>
>     https://lists.sourceforge.net/lists/listinfo/mspgcc-users
>
>

------------------------------------------------------------------------------
Monitor your physical, virtual and cloud infrastructure from a single
web console. Get in-depth insight into apps, servers, databases, vmware,
SAP, cloud infrastructure, etc. Download 30-day Free Trial.
Pricing starts from $795 for 25 servers or applications!
http://p.sf.net/sfu/zoho_dev2dev_nov
_______________________________________________
Mspgcc-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mspgcc-users
Reply | Threaded
Open this post in threaded view
|

Re: Fedora 17 RPM bundle, was Re: mcu install conflict - should I care?

Peter Bigot-4
And msp430mcu, and possibly msp430-gdb.

Peter

On Sat, Nov 24, 2012 at 9:58 AM, Yama Ploskonka <[hidden email]> wrote:

> I might be able to find someone to package the thing, or might try the
> list also
>
> Question: what needs to be packaged (files, dependencies?)
> so far I know of
>
> mspdebug
> msp430-libc
> msp430-binutils
> msp430-gcc
>
> Thank you!
>
>
>
> On 11/24/2012 05:23 AM, Peter Bigot wrote:
>
>> Looks like the RPM packages for mspgcc you're finding are extremely out
>> of date; mspgcc 3.2.3 is no longer supported. There was somebody who was
>> bundling more recent ones, but  I haven't seen anything from him recently.
>>
>> The msp430mcu package is irrelevant to the version of mspgcc you get with
>> those RPMs, and that version wouldn't work with the launchpad.
>>
>> If you need a package-based solution, you'll need to find somebody who
>> has current (LTS-20120406, probably) RPMs available. Alternatively you can
>> build the LTS version or the most recent development version manually;
>> there are general instructions on the Wiki.
>>
>> Peter
>>
>>
>> On Fri, Nov 23, 2012 at 10:45 PM, Yama Ploskonka <[hidden email]<mailto:
>> [hidden email]>> wrote:
>>
>>     Should I care that when trying to install msp430mcu there is a
>>     conflict?
>>
>>     The code I have been using for testing compiles OK - I actually
>>     have no idea what mcu is for, or whether I need it at all. Were it
>>     not that
>>     http://sourceforge.net/apps/**mediawiki/mspgcc/index.php?**
>> title=MSPGCC_Wiki<http://sourceforge.net/apps/mediawiki/mspgcc/index.php?title=MSPGCC_Wiki>
>>     says "The msp430mcu
>>     <http://sourceforge.net/**projects/mspgcc/files/**msp430mcu<http://sourceforge.net/projects/mspgcc/files/msp430mcu>>
>> package
>>     must be installed to provide header and linker support." I would
>>     not worry.
>>
>>     I've been having assorted difficulties compiling for Launchpad run
>>     from OLPC XO, so I decided to reinstall the OS, load the mspdebug
>>     toolchain from zero.
>>
>>
>>
>>     (follows log of install in OLPC XO-1, using OLPC OS 2021o0 release
>>     12.1.0)
>>
>>      Dup dor a'az Mubster!              \_____/    Bonjour, enfants du
>>     monde!
>>      Ciao, bambini di tutto il mondo!   || o ||    ĄHola, chicos del
>>     mundo!
>>      Hallo, Kinder der Welt!            |._X_.|    Hallo, kinderen van
>>     de wereld!
>>      Hello, children of the world!     //_=_=_\\   Olá, crianças do mundo!
>>
>>     [olpc@xo-12-37-77 ~]$ cd Documents/
>>     [olpc@xo-12-37-77 Documents]$ sudo yum install mspdebug msp430-libc
>>     fedora/metalink                                          |  19 kB
>>         00:00
>>     fedora                                                   | 4.2 kB
>>         00:00
>>     fedora/primary_db                                        |  12 MB
>>         00:39
>>     olpc-f17                                                 |  951 B
>>         00:00
>>     olpc-f17/primary                                         |  17 kB
>>         00:00
>>     olpc-f17 82/82
>>     olpc-f17-xo1                                             |  951 B
>>         00:00
>>     olpc-f17-xo1/primary                                     |  19 kB
>>         00:00
>>     olpc-f17-xo1 190/190
>>     updates/metalink                                         |  12 kB
>>         00:00
>>     updates                                                  | 4.7 kB
>>         00:00
>>     http://fedora.mirror.constant.**com/linux/updates/17/i386/**
>> repodata/repomd.xml<http://fedora.mirror.constant.com/linux/updates/17/i386/repodata/repomd.xml>
>> :
>>     [Errno -1] repomd.xml does not match metalink for updates
>>     Trying other mirror.
>>     updates                                                  | 4.7 kB
>>         00:00
>>     updates/primary_db                                       | 5.6 MB
>>         00:16
>>     Resolving Dependencies
>>     --> Running transaction check
>>     ---> Package msp430-libc.noarch 0:0-5.20090726cvs.fc17 will be
>>     installed
>>     --> Processing Dependency: msp430-gcc for package:
>>     msp430-libc-0-5.20090726cvs.**fc17.noarch
>>     ---> Package mspdebug.i686 0:0.20-1.fc17 will be installed
>>     --> Running transaction check
>>     ---> Package msp430-gcc.i686 0:3.2.3-6.20100805cvs.fc17 will be
>>     installed
>>     --> Processing Dependency: msp430-binutils for package:
>>     msp430-gcc-3.2.3-6.**20100805cvs.fc17.i686
>>     --> Running transaction check
>>     ---> Package msp430-binutils.i686 0:2.19.1-4.fc17 will be installed
>>     --> Finished Dependency Resolution
>>
>>     Dependencies Resolved
>>
>>     ==============================**==============================**
>> ====================
>>      Package             Arch       Version Repository   Size
>>     ==============================**==============================**
>> ====================
>>     Installing:
>>      msp430-libc         noarch     0-5.20090726cvs.fc17 fedora      204 k
>>      mspdebug            i686       0.20-1.fc17 updates     109 k
>>     Installing for dependencies:
>>      msp430-binutils     i686       2.19.1-4.fc17 fedora  1.3 M
>>      msp430-gcc          i686       3.2.3-6.20100805cvs.fc17 fedora
>>   1.2 M
>>
>>     Transaction Summary
>>     ==============================**==============================**
>> ====================
>>     Install  2 Packages (+2 Dependent packages)
>>
>>     Total download size: 2.8 M
>>     Installed size: 19 M
>>     Is this ok [y/N]: y
>>     Downloading Packages:
>>     (1/4): msp430-binutils-2.19.1-4.fc17.**i686.rpm            | 1.3 MB
>>         00:04
>>     warning: rpmts_HdrFromFdno: Header V3 RSA/SHA256 Signature, key ID
>>     1aca3465: NOKEY
>>     Public key for msp430-binutils-2.19.1-4.fc17.**i686.rpm is not
>> installed
>>     (2/4): msp430-gcc-3.2.3-6.**20100805cvs.fc17.i686.rpm      | 1.2 MB
>>         00:03
>>     (3/4): msp430-libc-0-5.20090726cvs.**fc17.noarch.rpm       | 204 kB
>>         00:00
>>     (4/4): mspdebug-0.20-1.fc17.i686.rpm                     | 109 kB
>>         00:00
>>     Public key for mspdebug-0.20-1.fc17.i686.rpm is not installed
>>     ------------------------------**------------------------------**
>> --------------------
>>     Total                                           276 kB/s | 2.8 MB
>>         00:10
>>     Retrieving key from file:///etc/pki/rpm-gpg/RPM-**GPG-KEY-fedora-i386
>>     Importing GPG key 0x1ACA3465:
>>      Userid     : "Fedora (17) <[hidden email]
>>     <mailto:fedora@fedoraproject.**org <[hidden email]>>>"
>>      Fingerprint: cac4 3fb7 74a4 a673 d81c 5de7 50e9 4c99 1aca 3465
>>      Package    : fedora-release-17-1.noarch
>>     (@koji.dist-f17-i686/$**releasever)
>>      From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-**fedora-i386
>>     Is this ok [y/N]: y
>>     Running Transaction Check
>>     Running Transaction Test
>>     Transaction Test Succeeded
>>     Running Transaction
>>       Installing : msp430-binutils-2.19.1-4.fc17.**i686
>> 1/4
>>       Installing : msp430-gcc-3.2.3-6.**20100805cvs.fc17.i686
>>          2/4
>>       Installing : msp430-libc-0-5.20090726cvs.**fc17.noarch
>>       3/4
>>       Installing : mspdebug-0.20-1.fc17.i686                4/4
>>
>>
>>     Rpmdb checksum is invalid: dCDPT(pkg checksums):
>>     msp430-libc.noarch 0:0-5.20090726cvs.fc17 - u
>>     [olpc@xo-12-37-77 Documents]$ ls
>>     m2.c  shiftl2.c  shiftl.c  text.c
>>
>>     // the following is a test of the compiler
>>
>>     [olpc@xo-12-37-77 Documents]$ msp430-gcc -g shiftl.c -o t
>>     [olpc@xo-12-37-77 Documents]$ ls
>>     m2.c  shiftl2.c  shiftl.c  t  text.c
>>
>>     // trying to install the mcu
>>
>>     [olpc@xo-12-37-77 Documents]$ sudo yum install msp430mcu
>>     Resolving Dependencies
>>     --> Running transaction check
>>     ---> Package msp430mcu.noarch 0:20120406-4.fc17 will be installed
>>     --> Processing Conflict: msp430mcu-20120406-4.fc17.**noarch
>>     conflicts msp430-libc < 20120224
>>     --> Finished Dependency Resolution
>>     Error: msp430mcu conflicts with
>>     msp430-libc-0-5.20090726cvs.**fc17.noarch
>>      You could try using --skip-broken to work around the problem
>>      You could try running: rpm -Va --nofiles --nodigest
>>
>>     // also, the include looks thin - but so far works...
>>
>>     [olpc@xo-12-37-77 Documents]$ ls /usr/msp430/include
>>     ctype.h        msp430x11x.h   msp430x20x3.h  msp430x31x.h
>>     msp430xG42x0.h
>>     debug.h        msp430x12x2.h  msp430x21x1.h  msp430x32x.h
>>     msp430xG43x.h
>>     errno.h        msp430x12x.h   msp430x21x2.h  msp430x33x.h
>>     msp430xG461x.h
>>     io.h           msp430x13x1.h  msp430x22x2.h  msp430x41x.h
>>     msp430xW42x.h
>>     iomacros.h     msp430x13x.h   msp430x22x4.h  msp430x42x0.h  setjmp.h
>>     isr_compat.h   msp430x14x1.h  msp430x23x0.h  msp430x42x.h signal.h
>>     limits.h       msp430x14x.h   msp430x23x.h   msp430x43x.h stdint.h
>>     math.h         msp430x15x.h   msp430x241x.h  msp430x44x.h stdio.h
>>     msp430         msp430x16x.h   msp430x24x1.h  msp430x47xx.h  stdlib.h
>>     msp430x11x1.h  msp430x20x1.h  msp430x24x.h   msp430x54xx.h  string.h
>>     msp430x11x2.h  msp430x20x2.h  msp430x261x.h  msp430xE42x.h  sys
>>     [olpc@xo-12-37-77 Documents]$
>>
>>
>>
>>     ------------------------------**------------------------------**
>> ------------------
>>     Monitor your physical, virtual and cloud infrastructure from a single
>>     web console. Get in-depth insight into apps, servers, databases,
>>     vmware,
>>     SAP, cloud infrastructure, etc. Download 30-day Free Trial.
>>     Pricing starts from $795 for 25 servers or applications!
>>     http://p.sf.net/sfu/zoho_**dev2dev_nov<http://p.sf.net/sfu/zoho_dev2dev_nov>
>>     ______________________________**_________________
>>     Mspgcc-users mailing list
>>     Mspgcc-users@lists.**sourceforge.net<[hidden email]>
>>     <mailto:Mspgcc-users@lists.**sourceforge.net<[hidden email]>
>> >
>>     https://lists.sourceforge.net/**lists/listinfo/mspgcc-users<https://lists.sourceforge.net/lists/listinfo/mspgcc-users>
>>
>>
>>
>
>
> ------------------------------------------------------------------------------
> Monitor your physical, virtual and cloud infrastructure from a single
> web console. Get in-depth insight into apps, servers, databases, vmware,
> SAP, cloud infrastructure, etc. Download 30-day Free Trial.
> Pricing starts from $795 for 25 servers or applications!
> http://p.sf.net/sfu/zoho_dev2dev_nov
> _______________________________________________
> Mspgcc-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/mspgcc-users
>
>

------------------------------------------------------------------------------
Monitor your physical, virtual and cloud infrastructure from a single
web console. Get in-depth insight into apps, servers, databases, vmware,
SAP, cloud infrastructure, etc. Download 30-day Free Trial.
Pricing starts from $795 for 25 servers or applications!
http://p.sf.net/sfu/zoho_dev2dev_nov
_______________________________________________
Mspgcc-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mspgcc-users