What the [bleep] is going on?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

What the [bleep] is going on?

Reginald Beardsley
I just made a fresh install of CentOS 6.7 and installed the latest Energia and Arduino IDEs.  ALL of these fail because the Gnu toolchains want libc-2.15.so whereas CentOS 6.7 only has 2.12 available.

Building 2.15 from source and substituting it did NOT go well, however I was able to recover the system.  I'm about to rebuild the MSP430 toolchain from source, but the gcc versioning is baffling.  I'm told one place it's based on gcc 5.x, but the strings in the latest Energia executables reference 4.4.x and 4.6.x.

CentOS 7 fails to install and Ubuntu 14.04 LTS hangs.  I chose CentOS 6.x because it seems to be the only thing that will even come close to working with all the various dev tools I want to use.  I don't care what distro I run, but I do care that it work with all the various dev tool chains (STM32, MSP430,Stellaris, Arduino, etc)

Would someone who has this working please sort out the versioning and dependencies?  And fix it. It has become VERY confusing.  Energia-1.6.10R18 is a mess.  Yesterday the Board Manager wouldn't work.  Today it did, but when I select a TivaC board it fails because it can't find the executable for the compiler.   I've still not diagnosed that yet.  I'm still trying to get the '430 working.

This does not need to be elaborate.  Just a summary of the source versions associated with the Energia releases.

I'm trying to get some MCU resources working for a school and this is ridiculously crap release engineering on all sides.   I was a release engineer back when X11 R3 came out supporting multiple platforms.  So I actually know how hard it is and what it takes to make it work properly.

The school will probably just use Windows, but I don't if I can possibly avoid it.  I need to be able to do things at home.

BTW the Energia-1.6.10R18 installer fails because the launcher tries to start a script called "arduino".  So no novice is going to have a successful install on Linux.  

Reg  

------------------------------------------------------------------------------
What NetFlow Analyzer can do for you? Monitors network bandwidth and traffic
patterns at an interface-level. Reveals which users, apps, and protocols are
consuming the most bandwidth. Provides multi-vendor support for NetFlow,
J-Flow, sFlow and other flows. Make informed decisions using capacity
planning reports. http://sdm.link/zohodev2dev
_______________________________________________
Mspgcc-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mspgcc-users
Loading...