Newcomer unable to compile a very simple program in ubuntu 13.04.

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Newcomer unable to compile a very simple program in ubuntu 13.04.

Sigmatec Automação e Sistemas

Hello,

I'm just starting to explore this platform and am unable to solve a
configuration issue (I guess) in the first program I try, very simple,
below. The set I use is the MSP430 Ultra-Low-Power MCUs eZ430-F2013
Development Tool with ubuntu v13.04. The installed MSP430 toolchain is
the default one from its apt-get command.
include "msp430x22x4.h"

volatile unsigned int i; // volatile to prevent optimization

void main(void)
{
WDTCTL = WDTPW + WDTHOLD; // stop watchdog timer
P1DIR |= 0X01; // set P1.0 to output direction

for(;;) {
P1OUT ^= 0x01; // toogle P1.0 exclusive-OR
i = 50000; // delay
do (i--);
while (i != 0);
}
}

When I try to compile it under ubuntu 13.04 I receive the error message
below,

sigmatech@sigmatech:~/Desktop/ESL/code/MSP430$ msp430-gcc hello_word.c
/usr/lib/gcc/msp430/4.6.3/../../../../msp430/bin/ld: cannot open linker
script file memory.x: No such file or directory
collect2: ld returned 1 exit
status/usr/lib/gcc/msp430/4.6.3/../../../../msp430/bin/ld: cannot open
linker script file memory.x: No such file or directory
collect2: ld returned 1 exit status

Could anyone help please?

TIA

Sigmatech
PS - is there an emacs mode available?





------------------------------------------------------------------------------
Get 100% visibility into Java/.NET code with AppDynamics Lite!
It's a free troubleshooting tool designed for production.
Get down to code-level detail for bottlenecks, with <2% overhead.
Download for free and get started troubleshooting in minutes.
http://pubads.g.doubleclick.net/gampad/clk?id=48897031&iu=/4140/ostg.clktrk
_______________________________________________
Mspgcc-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mspgcc-users
Reply | Threaded
Open this post in threaded view
|

Re: Newcomer unable to compile a very simple program in ubuntu 13.04.

Rahimov
Hi,
The Linker is looking for the ldscript file memory.x in your system and
cannot find it.. try to find it manually in your mspgcc installation folder
smth. like this folder

msp430\lib\ldscripts.. there should be this ld script file.. and try
to give the phad to your script in compiler options with option -T

-T scriptfile
       --script=scriptfile
           Use scriptfile as the linker script.  This script replaces ld’s
           default linker script (rather than adding to it), so commandfile
           must specify everything necessary to describe the output file.
           If scriptfile does not exist in the current directory, "ld" looks
           for it in the directories specified by any preceding -L options.

Hope it helps,

Regards



On Fri, Aug 9, 2013 at 1:21 PM, Sigmatec Automação e Sistemas <
[hidden email]> wrote:

>
> Hello,
>
> I'm just starting to explore this platform and am unable to solve a
> configuration issue (I guess) in the first program I try, very simple,
> below. The set I use is the MSP430 Ultra-Low-Power MCUs eZ430-F2013
> Development Tool with ubuntu v13.04. The installed MSP430 toolchain is
> the default one from its apt-get command.
> include "msp430x22x4.h"
>
> volatile unsigned int i; // volatile to prevent optimization
>
> void main(void)
> {
> WDTCTL = WDTPW + WDTHOLD; // stop watchdog timer
> P1DIR |= 0X01; // set P1.0 to output direction
>
> for(;;) {
> P1OUT ^= 0x01; // toogle P1.0 exclusive-OR
> i = 50000; // delay
> do (i--);
> while (i != 0);
> }
> }
>
> When I try to compile it under ubuntu 13.04 I receive the error message
> below,
>
> sigmatech@sigmatech:~/Desktop/ESL/code/MSP430$ msp430-gcc hello_word.c
> /usr/lib/gcc/msp430/4.6.3/../../../../msp430/bin/ld: cannot open linker
> script file memory.x: No such file or directory
> collect2: ld returned 1 exit
> status/usr/lib/gcc/msp430/4.6.3/../../../../msp430/bin/ld: cannot open
> linker script file memory.x: No such file or directory
> collect2: ld returned 1 exit status
>
> Could anyone help please?
>
> TIA
>
> Sigmatech
> PS - is there an emacs mode available?
>
>
>
>
>
>
> ------------------------------------------------------------------------------
> Get 100% visibility into Java/.NET code with AppDynamics Lite!
> It's a free troubleshooting tool designed for production.
> Get down to code-level detail for bottlenecks, with <2% overhead.
> Download for free and get started troubleshooting in minutes.
> http://pubads.g.doubleclick.net/gampad/clk?id=48897031&iu=/4140/ostg.clktrk
> _______________________________________________
> Mspgcc-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/mspgcc-users
>

------------------------------------------------------------------------------
Get 100% visibility into Java/.NET code with AppDynamics Lite!
It's a free troubleshooting tool designed for production.
Get down to code-level detail for bottlenecks, with <2% overhead.
Download for free and get started troubleshooting in minutes.
http://pubads.g.doubleclick.net/gampad/clk?id=48897031&iu=/4140/ostg.clktrk
_______________________________________________
Mspgcc-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mspgcc-users
Reply | Threaded
Open this post in threaded view
|

Re: Newcomer unable to compile a very simple program in ubuntu 13.04.

Peter Bigot-4
No.  Unless you are using a custom linker script you never need to
reference it directly.  Use -mmcu=whatever when compiling and linking: that
adds the appropriate linker paths and compiler flags.

Only if that fails do you have a problem with msp430-mcu (the package that
provides the linker scripts), which may not be installed depending on what
apt-get command you ran.

Peter

On Fri, Aug 9, 2013 at 6:42 AM, Rahimov <[hidden email]> wrote:

> Hi,
> The Linker is looking for the ldscript file memory.x in your system and
> cannot find it.. try to find it manually in your mspgcc installation folder
> smth. like this folder
>
> msp430\lib\ldscripts.. there should be this ld script file.. and try
> to give the phad to your script in compiler options with option -T
>
> -T scriptfile
>        --script=scriptfile
>            Use scriptfile as the linker script.  This script replaces ld’s
>            default linker script (rather than adding to it), so commandfile
>            must specify everything necessary to describe the output file.
>            If scriptfile does not exist in the current directory, "ld"
> looks
>            for it in the directories specified by any preceding -L options.
>
> Hope it helps,
>
> Regards
>
>
>
> On Fri, Aug 9, 2013 at 1:21 PM, Sigmatec Automação e Sistemas <
> [hidden email]> wrote:
>
> >
> > Hello,
> >
> > I'm just starting to explore this platform and am unable to solve a
> > configuration issue (I guess) in the first program I try, very simple,
> > below. The set I use is the MSP430 Ultra-Low-Power MCUs eZ430-F2013
> > Development Tool with ubuntu v13.04. The installed MSP430 toolchain is
> > the default one from its apt-get command.
> > include "msp430x22x4.h"
> >
> > volatile unsigned int i; // volatile to prevent optimization
> >
> > void main(void)
> > {
> > WDTCTL = WDTPW + WDTHOLD; // stop watchdog timer
> > P1DIR |= 0X01; // set P1.0 to output direction
> >
> > for(;;) {
> > P1OUT ^= 0x01; // toogle P1.0 exclusive-OR
> > i = 50000; // delay
> > do (i--);
> > while (i != 0);
> > }
> > }
> >
> > When I try to compile it under ubuntu 13.04 I receive the error message
> > below,
> >
> > sigmatech@sigmatech:~/Desktop/ESL/code/MSP430$ msp430-gcc hello_word.c
> > /usr/lib/gcc/msp430/4.6.3/../../../../msp430/bin/ld: cannot open linker
> > script file memory.x: No such file or directory
> > collect2: ld returned 1 exit
> > status/usr/lib/gcc/msp430/4.6.3/../../../../msp430/bin/ld: cannot open
> > linker script file memory.x: No such file or directory
> > collect2: ld returned 1 exit status
> >
> > Could anyone help please?
> >
> > TIA
> >
> > Sigmatech
> > PS - is there an emacs mode available?
> >
> >
> >
> >
> >
> >
> >
> ------------------------------------------------------------------------------
> > Get 100% visibility into Java/.NET code with AppDynamics Lite!
> > It's a free troubleshooting tool designed for production.
> > Get down to code-level detail for bottlenecks, with <2% overhead.
> > Download for free and get started troubleshooting in minutes.
> >
> http://pubads.g.doubleclick.net/gampad/clk?id=48897031&iu=/4140/ostg.clktrk
> > _______________________________________________
> > Mspgcc-users mailing list
> > [hidden email]
> > https://lists.sourceforge.net/lists/listinfo/mspgcc-users
> >
>
>
> ------------------------------------------------------------------------------
> Get 100% visibility into Java/.NET code with AppDynamics Lite!
> It's a free troubleshooting tool designed for production.
> Get down to code-level detail for bottlenecks, with <2% overhead.
> Download for free and get started troubleshooting in minutes.
> http://pubads.g.doubleclick.net/gampad/clk?id=48897031&iu=/4140/ostg.clktrk
> _______________________________________________
> Mspgcc-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/mspgcc-users
>
>

------------------------------------------------------------------------------
Get 100% visibility into Java/.NET code with AppDynamics Lite!
It's a free troubleshooting tool designed for production.
Get down to code-level detail for bottlenecks, with <2% overhead.
Download for free and get started troubleshooting in minutes.
http://pubads.g.doubleclick.net/gampad/clk?id=48897031&iu=/4140/ostg.clktrk
_______________________________________________
Mspgcc-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mspgcc-users
Reply | Threaded
Open this post in threaded view
|

Re: Newcomer unable to compile a very simple program in ubuntu 13.04.

Sigmatec Automação e Sistemas
In reply to this post by Sigmatec Automação e Sistemas
Dear Adam,

Thanks for the reply and everyone else who replied as well. I should
express that if I include this header file instead it states the file
does exist despite its existence in the /usr/msp430/include directory.
Thus, I think the issues might be related with some kind of
$PATH-related setting. Would anyone know how to set it up, please?

TIA,

Sigmatech

On Fri, 2013-08-09 at 06:26 -0500, Adam Ford wrote:

> Include msp430f2013.h instead
>
>
> On Aug 9, 2013 6:23 AM, "Sigmatec Automação e Sistemas"
> <[hidden email]> wrote:
>
>        
>         Hello,
>        
>         I'm just starting to explore this platform and am unable to
>         solve a
>         configuration issue (I guess) in the first program I try, very
>         simple,
>         below. The set I use is the MSP430 Ultra-Low-Power MCUs
>         eZ430-F2013
>         Development Tool with ubuntu v13.04. The installed MSP430
>         toolchain is
>         the default one from its apt-get command.
>         include "msp430x22x4.h"
>        
>         volatile unsigned int i; // volatile to prevent optimization
>        
>         void main(void)
>         {
>         WDTCTL = WDTPW + WDTHOLD; // stop watchdog timer
>         P1DIR |= 0X01; // set P1.0 to output direction
>        
>         for(;;) {
>         P1OUT ^= 0x01; // toogle P1.0 exclusive-OR
>         i = 50000; // delay
>         do (i--);
>         while (i != 0);
>         }
>         }
>        
>         When I try to compile it under ubuntu 13.04 I receive the
>         error message
>         below,
>        
>         sigmatech@sigmatech:~/Desktop/ESL/code/MSP430$ msp430-gcc
>         hello_word.c
>         /usr/lib/gcc/msp430/4.6.3/../../../../msp430/bin/ld: cannot
>         open linker
>         script file memory.x: No such file or directory
>         collect2: ld returned 1 exit
>         status/usr/lib/gcc/msp430/4.6.3/../../../../msp430/bin/ld:
>         cannot open
>         linker script file memory.x: No such file or directory
>         collect2: ld returned 1 exit status
>        
>         Could anyone help please?
>        
>         TIA
>        
>         Sigmatech
>         PS - is there an emacs mode available?
>        
>        
>        
>        
>        
>         ------------------------------------------------------------------------------
>         Get 100% visibility into Java/.NET code with AppDynamics Lite!
>         It's a free troubleshooting tool designed for production.
>         Get down to code-level detail for bottlenecks, with <2%
>         overhead.
>         Download for free and get started troubleshooting in minutes.
>         http://pubads.g.doubleclick.net/gampad/clk?id=48897031&iu=/4140/ostg.clktrk
>         _______________________________________________
>         Mspgcc-users mailing list
>         [hidden email]
>         https://lists.sourceforge.net/lists/listinfo/mspgcc-users

------------------------------------------------------------------------------
Get 100% visibility into Java/.NET code with AppDynamics Lite!
It's a free troubleshooting tool designed for production.
Get down to code-level detail for bottlenecks, with <2% overhead.
Download for free and get started troubleshooting in minutes.
http://pubads.g.doubleclick.net/gampad/clk?id=48897031&iu=/4140/ostg.clktrk
_______________________________________________
Mspgcc-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mspgcc-users
Reply | Threaded
Open this post in threaded view
|

Re: Newcomer unable to compile a very simple program in ubuntu 13.04.

Sigmatec Automação e Sistemas
In reply to this post by Sigmatec Automação e Sistemas
Dear Yama,

I got it to compile finally! I added the msp430 directories to the PATH
variable in order to do it. However, when I try to compile with
different mmcus one of them does not compile and I do not know why. The
msp430f2013 and msp430g2231 mmcus compile ok but the msp430x22x4 mmcu
does not compile at all with the previous ld linker script memory.x.
What does it mean?

TIA,

Sigmatech

On Sat, 2013-08-10 at 08:21 -0500, Yama Ploskonka wrote:

> OK.
>
> Were you also using the -mmcu? Did using -mmcu make a difference?
>
>
>
> On 08/10/2013 05:25 AM, Sigmatec Automação e Sistemas wrote:
>
> >
> > Dear Yama,
> >
> > Thanks for the message. The lack of the # instead of #include was a
> > mistype, sorry.
> >
> > On Fri, 2013-08-09 at 22:58 -0500, Yama Ploskonka wrote:
> >
> > > If I am compiling for an msp430g2553, I will write this line
> > >
> > >     msp430-gcc hello_world.c -mmcu=msp430g2553
> > >
> > > output will be the file a.out
> > >
> > > No idea how to change this for eZ430-F2013, but you get the idea.
> > >
> > > Also, I would put a # before the include, as in
> > >
> > >     #include "msp430x22x4.h"
> > >
> > >
> > >
> > >
> > > On 08/09/2013 06:21 AM, Sigmatec Automação e Sistemas wrote:
> > > > Hello,
> > > >
> > > > I'm just starting to explore this platform and am unable to solve a
> > > > configuration issue (I guess) in the first program I try, very simple,
> > > > below. The set I use is the MSP430 Ultra-Low-Power MCUs eZ430-F2013
> > > > Development Tool with ubuntu v13.04. The installed MSP430 toolchain is
> > > > the default one from its apt-get command.
> > > > include "msp430x22x4.h"
> > > >
> > > > volatile unsigned int i; // volatile to prevent optimization
> > > >
> > > > void main(void)
> > > > {
> > > > WDTCTL = WDTPW + WDTHOLD; // stop watchdog timer
> > > > P1DIR |= 0X01; // set P1.0 to output direction
> > > >
> > > > for(;;) {
> > > > P1OUT ^= 0x01; // toogle P1.0 exclusive-OR
> > > > i = 50000; // delay
> > > > do (i--);
> > > > while (i != 0);
> > > > }
> > > > }
> > > >
> > > > When I try to compile it under ubuntu 13.04 I receive the error message
> > > > below,
> > > >
> > > > sigmatech@sigmatech:~/Desktop/ESL/code/MSP430$ msp430-gcc hello_word.c
> > > > /usr/lib/gcc/msp430/4.6.3/../../../../msp430/bin/ld: cannot open linker
> > > > script file memory.x: No such file or directory
> > > > collect2: ld returned 1 exit
> > > > status/usr/lib/gcc/msp430/4.6.3/../../../../msp430/bin/ld: cannot open
> > > > linker script file memory.x: No such file or directory
> > > > collect2: ld returned 1 exit status
> > > >
> > > > Could anyone help please?
> > > >
> > > > TIA
> > > >
> > > > Sigmatech
> > > > PS - is there an emacs mode available?
> > > >
> > > >
> > > >
> > > >
> > > >
> > > > ------------------------------------------------------------------------------
> > > > Get 100% visibility into Java/.NET code with AppDynamics Lite!
> > > > It's a free troubleshooting tool designed for production.
> > > > Get down to code-level detail for bottlenecks, with <2% overhead.
> > > > Download for free and get started troubleshooting in minutes.
> > > > http://pubads.g.doubleclick.net/gampad/clk?id=48897031&iu=/4140/ostg.clktrk
> > > > _______________________________________________
> > > > Mspgcc-users mailing list
> > > > [hidden email]
> > > > https://lists.sourceforge.net/lists/listinfo/mspgcc-users
> > >
> >
> >
>
>


------------------------------------------------------------------------------
Get 100% visibility into Java/.NET code with AppDynamics Lite!
It's a free troubleshooting tool designed for production.
Get down to code-level detail for bottlenecks, with <2% overhead.
Download for free and get started troubleshooting in minutes.
http://pubads.g.doubleclick.net/gampad/clk?id=48897031&iu=/4140/ostg.clktrk
_______________________________________________
Mspgcc-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mspgcc-users
Reply | Threaded
Open this post in threaded view
|

Re: Newcomer unable to compile a very simple program in ubuntu 13.04.

Yama Ploskonka-2
HI Sigma

congratulations. I had forgotten good old PATH issues (though for some
reason I didn't need it in my Kubuntu 12.04, everythting went fine using
Muon , I recall fighting that battle with some earlier Ubuntu distro)

could you copy the exact line you are using? I am unsure if you are
trying to use "x" as a wildcard (will not work AFAIK)




On 08/10/2013 07:36 PM, Sigmatech Automacao e Sistemas wrote:

> Dear Yama,
>
> I got it to compile finally! I added the msp430 directories to the
> PATH variable in order to do it. However, when I try to compile with
> different mmcus one of them does not compile and I do not know why.
> The msp430f2013 and msp430g2231 mmcus compile ok but the msp430x22x4
> mmcu does not compile at all with the previous ld linker script
> memory.x. What does it mean?
>
> TIA,
>
> Sigmat

------------------------------------------------------------------------------
Get 100% visibility into Java/.NET code with AppDynamics Lite!
It's a free troubleshooting tool designed for production.
Get down to code-level detail for bottlenecks, with <2% overhead.
Download for free and get started troubleshooting in minutes.
http://pubads.g.doubleclick.net/gampad/clk?id=48897031&iu=/4140/ostg.clktrk
_______________________________________________
Mspgcc-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mspgcc-users